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Disclaimer 
Nothing on Old School Value, related pages, emails, or other communications by the author, either written or oral, are intended 

to be a recommendation to buy, hold, or sell any specific security or group of securities. Likewise, nothing herein should be 

construed as an endorsement of any financial adviser, investment manager, commercial information provider, transaction 

service, or brokerage firm. 

The findings from this spreadsheet are merely a start to a means of further research and uncovering a great business and 

investment. Old School Value holds no responsibility for any investment whatsoever. 

Read Me First… PLEASE. 
A step by step guide in text is in the 01.Readme_FIRST.txt file. 
 
When you unzip the package it contains 

- 01.Readme text file 
-  02.Overview 
- RCH_Stock_Market_Functions.zip 
- OSV_Financial_Statement_Analysis-v .xls 
- 10yr_OSV_Stock_Valuation-v .xls 
- 05yr_OSV_Stock_Valuation-v .xls 
- Install_guide_FAQ.pdf 

 
The three XLS files are the spreadsheets. They do not open  automatically. You can cut or copy these 
files and save it anywhere you wish to run it from. 
 
The actual add-in is RCH_Stock_Market_Functions.zip which contains 12 text files, 
RCH_Stock_Market_Functions.xla, RCHGetElementNumber-Element-Definitions.xls 

 

If you do not know how to unzip, create new folders, or moving files around, check the 

troubleshooting section on unzipping. 

How to Install 
You need the following files. 

 The SMF Add-in included with the download (RCH_Stock_Market_Functions.zip) 

 The spreadsheets (05yr_OSV_Stock_Valuation.xls, 10yr_OSV_Stock_Valuation-v6.0.0.xls etc) 

 

1. Navigate to Local Disk C: in My Computer or Explorer 

2. Create a new folder called “SMF” without the quotations 

3. Copy or cut the RCH_Stock_Market_Functions.zip file to the SMF folder 

4. Unzip the contents to the directory. DO NOT unzip the contents inside another folder. All the 

contents should be within the SMF Add-In folder. See below. 

I repeat DO NOT unzip the contents inside another folder. 
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5. Start Microsoft Excel 

 

For Excel 2003 

1. Go to the Tools menu and click Add-Ins 
2. Click the Browse button and a window will appear 
3. Click browse to and navigate to the SMF you created earlier 
4. Select the Add in file (you should only be seeing one) and then click OK 
5. Click Yes to any file copy or overwrite prompts if there is any 
6. Verify the Stock Market Function add in box is checked 
7. Press OK 

For Excel 2007 

1. Click the Windows Orb and then click on Excel Options in the bottom right corner 
2. On the left menu, click Add-Ins 
3. Towards the bottom there is a drop down list called Manage. Select Excel Add-ins and click Go 
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4. The add ins window will appear and click on Browse 
5. Navigate to the SMF you created earlier 
6. Select the Add in file (you should only be seeing one) and then click OK  

 

7. Click Yes to any file copy or overwrite prompts if there is any 
8. Verify the Stock Market Function add in box is checked 
9. Press OK 

 

6. Close Excel 
7. Start Excel again and open the Old School Value spreadsheet 
8. If everything has been set up properly, in the bottom right corner of Excel, you should see a 

“Calculating xx%” or press F9 to start the calculation. This is the spreadsheet accessing and pulling 
information from the online databases. 
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Congratulations! You have it all set up and ready for use. 
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Troubleshooting 

1. How to customize the spreadsheet 

The spreadsheet utilizes an excel add-in called SMF (Stock Market Function). For other spreadsheets and 

templates with this add-in, visit the Yahoo page, sign up and navigate to the files section. 

In the OSV spreadsheets, the data in the statements tab is retrieved from Morningstar with the 
=RCHGetTableCell() function. Simply, this grabs the value from the cell of the table. 

Currently the formula in the spreadsheet is: 
=RCHGetTableCell("http://quicktake.morningstar.com/Stock/ Income10.asp?Symbol="&Ticker, 2, 
"Fiscal Year-End:", ">Revenue") 

To grab data from another site such as Yahoo Finance Australia for Telstra, I could go to the balance 
sheet page and then edit the function to display the cash by entering the following 

=RCHGetTableCell("http://au.finance.yahoo.com/q/abs?s="&Ticker, 1, "PERIOD ENDING", ">Cash") 
where the ticker entered into the spreadsheet would be TLS.AX. 

This command does the following: 

 points to the page http://au.finance.yahoo.com/q/abs?s=TLS.AX 
 selects the table that contains the exact phrase "PERIOD ENDING" 
 selects the very first cell right after the cell containing the exact phrase "CASH" which is 

characterized by the > sign. 

To retrieve the next value from the table, you would simply change the 1 to 2 to get the second cell. 

2. Update Link Popup Errors – Most Common Issue 

The most common issue. You will get an update link error because you did not unzip the add-in to the 

correct folder. 

It has to be in c:\SMF but most people unknowingly unzip it to a subfolder within the SMF directory. 

If you look at the next image, you will see how there is no subfolder within the folder. So cut or move 
ALL the files from the subfolder to the c:\SMF\ directory. 

Excel saves the location of the add-in directly into the spreadsheet. Since I have the add-in located in 
c:\SMF\ the spreadsheets that I have on the site and you purchase will be looking the add-in in this 
directory. 

http://finance.groups.yahoo.com/group/smf_addin/
http://au.finance.yahoo.com/q/abs?s=TLS.AX
http://au.finance.yahoo.com/q/abs?s=TLS.AX
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But if you believe you did everything correctly and you are still getting update link errors, start by doing 
the following. 

Open the spreadsheet, go to the Statements tab and click on any cell in the middle of the worksheet. 

You will notice that in front of the formula you will see a path directory  i.e. rather than just see 
=RCHGetTableElement() you will see something like 

D:\SMF\RCH_Stock_Market_Functions.xla'!RCHGetTableElement() 

It is listing the directory because excel is trying to find the add-in in a different directory. In this example, 
excel is looking for the add-in file RCH_Stock_Market_Functions.xla' from D:\SMF\ but I have it under 
C:\SMF\ 

Solution 

When you see the following box display upon opening the spreadsheet, do the following 

 

Click on “Edit Links…” 
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A new window will display. Notice how it says D:\SMF Add-in in the location in the bottom left. 

Also, in the status column, it shows “Error: Source not found”. 

To update the location, click on “Change Source…”. If the change source button is grayed out, do the 
following. 

1. Press the close button to close the edit links window 
2. Select each tabor worksheet and make sure it is unprotected or unlocked. I did not set 

any password so simply press unprotect. It must be unprotected for the change source 
option to work. 

3. Save the spreadsheet 
4. Reopen the spreadsheet to start the process again 
5. Change Source should be selectable now 

Another window is displayed showing your folders 

Navigate to where you installed the add-in. In my case, I have it under C:\SMF\ so I will navigate to the 
folder where I will then select “RCH_Stock_Market_Functions.xla” and click OK. 
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Select “RCH_Stock_Market_Functions.xla” and click OK 

 

Now the location has been updated and as long as the Status does not show ERROR, it is working. This 
means that excel has now properly found the add-in. 

Click “Close”. 

Now press F9 to refresh and the spreadsheet should now work. Verify that the location has been 
updated by clicking on a cell and seeing whether the cell formula is something like 
=RCHGetTableElement() rather than D:\SMF Add-in\RCH_Stock_Market_Functions.xla'! at the front. 

 Save the spreadsheet and you are finished. 
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3. How to Re-install 

In this case, do the following from the 01.Readme_FIRST.txt file 

Only U.S. companies or ADR’s will work. 

Pre setup if add-in is installed other than C:/SMF 

A. open excel 
B. go to the add in section in your version of excel and deselect and delete the add in from the list 
C. close excel 
D. delete the C:\SMF folder completely 
E. log off and log in again or restart computer. Excel has to completely clear its cache and memory 

in order to update the add-in's new location. 
Setup 

1. download the zipped file. 
2. Go to my computer > go to C:\ 
3. create a new folder > name it "SMF" 
4. move the zipped file to C:\SMF 
5. right click the file and unzip to the current C:\SMF folder. If you unzip and it creates another 

folder automatically, move all the contents from that folder back to C:\SMF. 
6. there will be another zipped file called RCH_Stock_market_Functions-2.0k.zip 
7. right click and unzip again. Make sure ALL the files are in C:\SMF and not in a sub-directory. ALL 

txt and xla files are to be in the same folder. 
8. Open excel 2003 or 2007 
9. Go to add-in menu in 2003 or excel options from the orb for 2007 and then add-ins 
10. Click the button to open the add-in browse. Click the Browse button and a window will appear 
11. Click browse to and navigate to the SMF you created earlier 
12. Select the Add in file (you should only be seeing one) and then click OK 
13. Click ok to close 
14. double click the file labeled 5y_OSVxx or 10yr_OSVxx or OSV_xx 
15. press F9 
16. in the bottom right corner you should see "Calculating". That's it. 

4. DIV errors 

DIV errors are due to calculations with a null value. This is usually the case when a range of cells include 

a cell showing DIV or a formula is trying to divide by 0 or something similar. 

To eliminate the DIV error, try readjusting the cell ranges as shown in the example below. 

For companies such as DLB with 4 years of data instead of the required 5, you will get #DIV/0! errors 
because Excel is trying to calculate the median with invalid numbers. 
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To overcome this, you simply have to restate the cell ranges by double clicking and then changing the 
range from =MEDIAN(B41:J41) to where there are actual values. In the case of DLB, this would be 
=MEDIAN(F41,I41;J41). 

 

The screenshot shows the edit for the third row, but you would want to do it for the first row and then 
just grab the corner and drag it down to apply it to all cells. 

5. Value! errors 

This error occurs because the spreadsheet is unable to retrieve the particular data for the given 

company from the online databases. You just have to wait for the databases to be updated or refreshed.  

6. ERROR errors 

The spreadsheet was working find until yesterday but now doesn’t work when a ticker is entered. This 

could be due to: 

1. Occassional database issues with the website the spreadsheet is retrieving data from. 

 

2. SMF Add-in installed incorrectly or Excel not being able to find where the add-in file is located. 

Fix this by following the install steps discussed previously. 
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3. The entered ticker is either a company Morningstar does not have data for OR the information 

for that particular company is down. 

 

To check this, go directly to Morningstar.com, enter the ticker, and click on Financial Statements in the 

menu. If you see all the numbers, contact me. If not, the Morningstar database is down. You can either 

contact Morningstar directly to have them look into it or wait a day or so.  

7. Financial companies doesn’t work 

The financial statements for financial companies are different to all the other companies. Financial 

companies usually don’t have a Statement of Cash Flows which we require. 

Without proper cash information or FCF values, performing a Discounted Cash Flow analysis is difficult 

and beyond the capabilities of this spreadsheet. 

8. It doesn’t run on my other computer. 

You have unzipped it within another folder. If it still doesn’t work be sure to follow the exact instructions 

in the how to reinstall section above. 

9. Speed up Load Time and Performance 

For Excel 2003 

Open the spreadsheet.  Go to Tools -> Options 

 

The default value is automatic as in the figure above. Check “manual”, and untick “Recalculate before 

save” and save. 

You now have to press F9 after entering the ticker or updating any cell.  
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Save the Excel file before closing so that it saves the setting. 

For Excel 2007 

Go to the Calculation group on the Formulas tab and select Manual 

 

To see more Excel 2007 calculation options, click the Microsoft Office Button, click Excel Options, and 

then click the Formulas tab. 

Calculation options on the Formula tab in Excel Options 

 

Many calculation options (Automatic, Automatic except tables, Manual, Calculate before save) 
and the iteration settings (Iteration on/off, Max iterations, Max change) operate at the 
application level rather than at the workbook level (they are the same for all open workbooks).  

To find advanced calculation options, click the Microsoft Office Button, click Excel Options, and 
then click Advanced. 
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10. Enable Macros to solve Link Must be Updated Errors 

If you come across an error when starting the spreadsheet stating that a link has to be updated , 

make sure macros are enabled. 

11. How to Unzip 

http://consumerdocs.installshield.com/selfservice/viewContent.do?externalId=Q108326&sliceId=1 

 

Remember that this is just an example of how to unzip so make sure you unzip to the proper folder. 

Double-click the zipped file. 

 

In the window that opens, click Extract all files. 

 

http://consumerdocs.installshield.com/selfservice/viewContent.do?externalId=Q108326&sliceId=1
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The Extraction Wizard opens. 

 

Click Next. 

In the Select a Destination panel, select the location where you want the folder to be placed, for 

example, the Desktop. Click Next. 

 

In the Extraction Complete panel, select Show extracted files. Check Finish. The unzipped files appear in 

a new window. 
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Use the contents of the zipped file as instructed in the solution. 

 

From experience these are all the issues encountered with running the spreadsheet. If you believe it is 

something else, leave a comment in the forum. 

http://www.oldschoolvalue.com/forum/

